Sunday, February 22, 2009

Frankie Gets Some Fixes

It has been very overdue to get Frankie updated to work with the latest versions of Sinatra and Facebooker.

But where I have been lagging, mjfreshyfresh has stepped up, and submitted a patch that gives compatibility with Sinatra 0.9.x and Facebooker 1.0.2. Thanks, my main man!

The Frankie gem has been updated to version 0.3, and it is available at your convenience. Note that you really do appear to need the 1.0.2 version of Facebooker for this release. Make sure you install facebooker using -v=1.0.2 to get only that version.

Let's all go huge on Facebook!


Liam O'Connor said...

I was unable to get frankie to work.


gem install facebooker -v=1.0.2

causes gem to say it can't find it, so i just installed whatever version was available.

Then, frankie complained when i tried to use it that the mmangino-facebooker gem wasn't installed, so I went

gem install mmangino-facebooker -v=1.0.2

This installed, and then, after attempting to run my frankie program again, I got this

/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- facebooker/models/applicationrestrictions (LoadError)
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /usr/lib/ruby/gems/1.8/gems/facebooker-1.0.13/lib/facebooker.rb:164
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /usr/lib/ruby/gems/1.8/gems/frankie-0.3.0/lib/frankie.rb:33

Ron Evans said...

I see from this line:
from /usr/lib/ruby/gems/1.8/gems/facebooker-1.0.13/lib/facebooker.rb:164

that you must have the 1.0.13 version of facebooker installed, which makes some breaking changes for frankie. You should uninstall that version, and make sure that no other versions of facebooker are installed except for the 1.0.2 version.

Petero said...

Facebooker 1.0.2 seems not to be there in the repository. :(